Skip to main content

Prerequisite

info

Badaso assumes that the user is familiar with the basics of Laravel and Vue. Therefore Badaso doesn't explain how to use Laravel or Vue.

Before installing Badaso, make sure the laravel you are using is supported by Badaso. The following is the environment Badaso needs:

PHP#

Badaso v2.x

  • PHP 8.x

Badaso v1.x

  • PHP 7.x

Composer#

  • Composer 2

Laravel#

Badaso v2.x

  • Laravel 8.x

Badaso v1.x

  • Laravel 5.x
  • Laravel 6.x
  • Laravel 7.x

Node#

  • Node 14.x

NPM#

  • NPM 6.x

Yarn#

  • Yarn 1.22.x